Am 25.05.2018 wird die neue EU-Datenschutz-Grundverordnung (EU-DSGVO) als einheitliche europäische Datenschutzregelung eingeführt.
Gleichzeitig wurde das Bundesdatenschutzgesetz (BDSG) überarbeitet und tritt gemeinsam mit der EU-DSGVO zum 25.05.2018 in Kraft.
Entsprechend dieser neuen Vorgaben haben wir unsere Datenschutzerklärung überarbeitet.

Ihr findet diese Datenschutzerklärung im Unterforum
"Wichtige Informationen" viewforum.php?f=12

Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Infos und Fragen zu Rechnern, Software & Co.

Moderator: Moderation

aseptisch
Senior Member
Beiträge: 260
Registriert: 11.09.2014, 16:29
Ort: Kiel
Ort: Kiel

Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon aseptisch » 04.10.2015, 00:49

Ich habe einen Dell-Laptop mit Core 2 Duo-Prozessor und Win7 32 Bit, mit dem ich über ein über Firewire verbundenes "Focusrite Liquid Saffire 56" mit bis zu 2 Octopre-Erweiterungen über ADAT keine Probleme auch bei Aufnahmen mit 24 Kanälen habe. Aufgenommen wird mit Samplitude Music Studio 2014. Für Aufnahmen schalte ich die Win Firewall, Win Update und den Win Defender Echtzeitschutz aus.

Da Firewire immer mehr ausstirbt, habe ich mal das USB-2.0-Pendant "Focusrite Scarlett 18i20" gebraucht ersteigert. Damit meldet Samplitude bei Aufnahme auf 2 Kanälen 44,1 kHz ca. 5 Aufnahmefehler pro 10 Sekunden bei 10 ms Latenz-Einstellung in Treiber. Hören oder sehen kann ich von den Fehlern allerdings nichts. Beim einstellbaren Maximum von 20 ms sind es weniger gemeldete Fehler, bei 1 ms treten auch harte Knackser auf, die in der Waveform als fehlende Daten sichtbar sind. Erhöhen der VIP-Puffer in Samplitude hat keinen Effekt auf das Problem.

Allerdings ist die Fehlerrate bei 48 oder 96 kHz niedriger, und bei 8 oder gar 16 Kanälen Aufnahme trat fast gar kein Fehler über Minuten auf.

Mit einem schwachbrüstigen Netbook mit Win7 bekam ich bei 2 Ch 44,1 die gleiche Aussetzer-Quote.
Mit dem anderen Laptop habe ich hingegen über Jahre nie irgendwelche Aussetzer mit einem billigen M-Audio FastTrack Ultra mit 6 Kanälen gehabt (USB-Interface), auch jetzt nicht, hab' nochmal gegengecheckt.

Hat jemand einen Tip, wonach ich suchen könnte? Ist das Interface nicht ok?

(Bin heute über Tage nicht zuhause, lese und antworte abends gerne.)

Grosse_j
Senior Member
Beiträge: 295
Registriert: 12.07.2009, 16:36
Ort: Erlangen

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon Grosse_j » 04.10.2015, 09:56

Googlest DU "Audio PC optimieren"

findest Du Ratschläge z.B. die ersten beiden.

http://focusrite.de/answerbase/windows- ... optimieren
http://www.therainbows.eu/Windows_7_PC_ ... en_v12.pdf
auch Windows update Dienst auf manuell stellen

und dann
http://dj-lab.de/2012/02/dpc-latency-ch ... er-latenz/

Gruß
Grosse_j

Benutzeravatar
Hannes_F
Senior Member
Beiträge: 283
Registriert: 06.01.2010, 00:39
Ort: Seelze bei Hannover
Kontaktdaten:

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon Hannes_F » 07.10.2015, 01:39

Bei einem meiner Rechner half, nachdem alles andere probiert war, nur das vorübergehende Deaktivieren der Netzwerkkarte im Geräte-Manager. Das war's dann aber auch, damit läuft es.

Benutzeravatar
Hannes_F
Senior Member
Beiträge: 283
Registriert: 06.01.2010, 00:39
Ort: Seelze bei Hannover
Kontaktdaten:

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon Hannes_F » 07.10.2015, 01:43

P.S.: Sehr guter Beitrag darüber, warum eine schnellere CPU nicht immer besser für Audio geeignet ist:
http://vi-control.net/community/threads ... daw.46807/

aseptisch
Senior Member
Beiträge: 260
Registriert: 11.09.2014, 16:29
Ort: Kiel
Ort: Kiel

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon aseptisch » 07.10.2015, 13:06

Vielen Dank für die Links! Was Focusrite auf seiner Webseite schreibt, ist ja sehr umfassend. Ich habe das komplett durchgearbeitet und letztlich auch im Gerätemanager ALLES rausgeworfen, was ging, quasi bis auf Prozessor, RAM, Festplatte, Bildschirm und 1 USB-Port. Es hat alles überhaupt keinen Einfluss auf Aufnahme-Aussetzer:

ASIO Buffer 1 ms (Minimum): sehr viele Aussetzer (150 pro Minute)
10 ms: einige Aussetzer (10 pro Minute)
20 ms: wenige Aussetzer (5 pro Minute)

Das ist scheinbar unabhängig davon, wie gut das System laut Latency Checker ist, also alles optimiert auf dem Laptop oder nicht.

Aufnahme auf vielen Kanälen (8 oder 16) gibt merklich weniger Aussetzer als auf nur 2 Kanälen. (Vielleicht etwa die Hälfte.)

DPC Latency Checker zeigt, dass zum Zeitpunkt, wo der Treiber für das Scarlett 18i20 geladen wird (Öffnen eines Projekts in Samplitude), die Latenzzeit des Systems deutlich schlechter wird. Mit 3 ms ASIO-Buffer ist zwar alles noch im sehr grünen Bereich, aber mit einer wohl eher realistischen Einstellung von 10 ms ist es knapp unter Rot.

Bei System in Ruhe (kein Audio-Interface angeschlossen, keine Programme laufen) mahnt LatencyMon deutlich folgende Treiber an, die übermäßige Latenzen verursachen würden:

- ACPI.sys ("ACPI-Treiber für Windows NT")
- USBPORT.sys ("USB 1.1 & 2.0-Porttreiber")
- ATAPORT.sys ("ATAPI Driver Extension")

Die sind alle von Microsoft, Teil von Win 7, und sind aktuell.

Wie schon geschrieben, mit einem billigen USB-M-Audio-Interface habe ich noch nie überhaupt einen Aussetzer gehabt, und ich kann da bestimmt auf Buffergröße 128 Samples runter. Über Firewire habe ich mit einem Focusrite Saffire bei Aufnahmen von 1-24 Spuren noch nie Probleme gehabt. (Und da waren Treiber wie der etwas Latenz-störende WLAN-Treiber nicht deaktiviert.) Zwar mal am Anfang oder Ende einer Aufnahme ein Hopser, aber sonst nix. Also grundsätzlich kann man mit dem Laptop prima Audio aufnehmen.

Mir fällt nur noch ein:

- Das Focusrite Scarlett 18i20 ist defekt.
- Der zugehörige Treiber für 32-Bit Windows 7 funktioniert nicht richtig.
- Der Laptop hat irgendwas an seinem USB-Port, dass die Kommunikation mit dem Scarlett nicht richtig klappt.
- Magix Samplitude Music Studio 2014 kann nicht gut mit dem Treiber.

Hat jemand noch eine Idee?

Leider habe ich kein anderes Aufnahmeprogramm, das Pufferausfälle meldet. Audacity meldet nix. Auf meinem stationären Rechner mit Win 7 64-Bit habe ich ein WaveLab 8 LE, das bei Aufnahme mit dem Scarlett auch keine Aussetzer meldete. Entweder gab es keine, oder es wurden keine gemeldet.

Danke fürs Lesen!

Benutzeravatar
Hannes_F
Senior Member
Beiträge: 283
Registriert: 06.01.2010, 00:39
Ort: Seelze bei Hannover
Kontaktdaten:

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon Hannes_F » 07.10.2015, 15:10

Eine Frage: Warum nimmst Du mit kleiner Latenzzeit auf? Solange keine VST-Instrumente eine Rolle spielen, kann man die raufsetzen, ich verwende z. B. 4096 Samples.

aseptisch
Senior Member
Beiträge: 260
Registriert: 11.09.2014, 16:29
Ort: Kiel
Ort: Kiel

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon aseptisch » 07.10.2015, 15:38

Da hast Du Recht. Ich hab' das im Kopf gar nicht richtig ausmultipliziert, ich dachte, 10 ms als mittlere Einstellung wäre bei Weitem ausreichend, aber es sind ja nur 441 Samples. Man kann das im Treiber nur in Millisekunden einstellen, ganze Zahlen von 1 bis maximal 20, und das sind dann auch nur 882 Samples. Leider treten dann aber immer noch Aussetzer auf. Vielleicht könnte man in der Registry andere Werte reinhacken ... Aber es bleibt die Frage, warum die Kommunikation so wackelig ist.

Grosse_j
Senior Member
Beiträge: 295
Registriert: 12.07.2009, 16:36
Ort: Erlangen

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon Grosse_j » 07.10.2015, 16:16

Sind den die Netzwerkdienste, WLAN, WAN,.. alle auf manuell gestellt und auch der Windows update Dienst (einschl. der Empfehlungen von H. Schewe)?
Ich hatte das Focusrite 18i6 lange Zeit auf einem Netbook W7 Starter mit Atom N570 und einem RME Quadmic störungsfrei laufen mit der höchsten einstellbaren Latenz.

Gruß
Grosse_j

Benutzeravatar
Hannes_F
Senior Member
Beiträge: 283
Registriert: 06.01.2010, 00:39
Ort: Seelze bei Hannover
Kontaktdaten:

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon Hannes_F » 08.10.2015, 01:40

aseptisch hat geschrieben:Man kann das im Treiber nur in Millisekunden einstellen, ganze Zahlen von 1 bis maximal 20, und das sind dann auch nur 882 Samples.


Hmm ... vielleicht das Gerät mal vom Hersteller überprüfen lassen?

aseptisch
Senior Member
Beiträge: 260
Registriert: 11.09.2014, 16:29
Ort: Kiel
Ort: Kiel

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon aseptisch » 08.10.2015, 02:35

Ich habe jetzt nochmal im Detail alles getan, was T. Schewe empfohlen hat. Im Zweifel habe ich mehr deaktiviert. Firewall und Windows Update habe ich ohnehin immer aus, aber gerade das sieht er gar nicht als nötig an, da sie nichts tun, wenn keine Netzwerkverbindung besteht. Leider ist das Fehlerbild vollkommen resistent gegen Optimierung des Laptops. Allerdings geben mir die Ausführungszeiten des ATAPI-Treibers (Festplatte) zu denken, die LatencyMon ankreidet. Es gab gelegentlich plötzliche Peaks, wo angeblich 30 ms und einmal sogar 123 ms Ausführungzeit dieses Treibers reportet wurden. LatencyMon zeigt Mikrosekunden an, es waren also 123000 Mikrosekunden. Das geht natürlich gar nicht, trat aber nur einmal auf, ich hab' das Ding eine halbe Stunde laufen lassen. Ich könnte nun über das schwächere Netbook herfallen und es ebenfalls in 10 h Arbeit trimmen und gucken, wie sich das dann verhält.

Grosse_j
Senior Member
Beiträge: 295
Registriert: 12.07.2009, 16:36
Ort: Erlangen

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon Grosse_j » 08.10.2015, 09:16

Mal andere USB Ports probieren, ich erinner mich an einen RME Tipp zur Auswahl des am besten geeigneten USB Ports, der nicht mit einem zweiten geteilt wird (mal im RME Forum suchen)
Gruß
Grosse_j

aseptisch
Senior Member
Beiträge: 260
Registriert: 11.09.2014, 16:29
Ort: Kiel
Ort: Kiel

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon aseptisch » 08.10.2015, 11:23

Danke, dass Ihr so geduldig mitlest!

Die USB-Ports habe ich alle durchgetestet und im Gerätemanager immer nur einen aktiviert, bis ich wusste, welcher Eintrag welchem der drei Ports an der Rückseite zugeordnet ist. Bei der Darstellung der Geräte "nach Verbindung" sieht man auch, welches Gerät (z. B. der eingebaute SD-Kartenleser) auf demselben USB Root Hub liegt. Ich habe das Audio-Interface an allen drei vorhandenen Buchsen probiert, aber es ändert sich nichts.

Ich wollte beim letzten Post noch geschrieben haben, dass ich mit meinem M-Audio-USB-Interface ca. 3 Aussetzer pro Minute mit 128 Samples Puffergröße habe (das ist das einstellbare Minimum), schon mit 256 Samples keinen Aussetzer mehr. (2 Minuten aufgenommen.) Generell ist demnach eigentlich alles ok.

Ich versuch' heute abend nochmal was anderes und meld' mich wieder.

aseptisch
Senior Member
Beiträge: 260
Registriert: 11.09.2014, 16:29
Ort: Kiel
Ort: Kiel

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon aseptisch » 08.10.2015, 22:49

Es war nicht schwierig, mit Process Monitor mitzuschneiden, wo das Scarlett MixControl (Bedienoberfläche) in der Registry den Wert für die ASIO-Puffergröße ablegt. Er wird in Millisekunden abgelegt, also Werte von 1 bis 20, und wird wirklich nur geschrieben, wenn man explizit einen neuen Wert in der Oberfläche anwählt. Es nützte aber nichts, mit regedit mal 50 einzutragen, die Aussetzer blieben konstant.

Noch bedeutsamer war aber dies: Obwohl ich das sonst nicht tue, hatte ich mir von einem bekannten, sehr großen Online-Shop ein neues Scarlett 18i20 bestellt, das heute ankam. Es verhält sich identisch. Das Positive: Ich muss mich mit dem Verkäufer des gebrauchten nicht herumstreiten und besitze also ein heiles. Das Negative: Mein Problem ist nicht gelöst. Vermutlich wird es mit diesem Laptop auch nichts. Nach etwa 20 Stunden des Herumprobierens ist klar, dass ein signifikanter Fortschritt vielleicht nach weiteren 50 Stunden denkbar wäre. Die Lösung steht offensichtlich nicht kurz bevor. Also bleibt es zunächst bei dem Firewire-Interface, denn dieser Laptop hat ja noch Firewire.

aseptisch
Senior Member
Beiträge: 260
Registriert: 11.09.2014, 16:29
Ort: Kiel
Ort: Kiel

Re: Aussetzer mit USB-Interface (weniger je mehr Kanäle)

Beitragvon aseptisch » 15.10.2015, 01:09

Irgendwann hatte ich gemerkt, dass die Aussetzer relativ periodisch waren, ungefähr im 5-Sekunden-Takt bei Aufnahme von 2 Kanälen mit 44,1 kHz bei 10 ms Latenz-Einstellung. Jetzt stellte ich fest, dass es immer abwechselnd knapp über 4 Sekunden und knapp unter 5 Sekunden sind, also ganz regelmäßig. Mit dem gebrauchten und dem neuen Scarlett 18i20. Und mit dem einen wie dem anderen Laptop. (Core 2 Duo und Atom 550)

Ich habe schon mein DECT-Telefon stromlos gemacht und auch alles mal im Schlafzimmer aufgebaut, aber das hat keinen Einfluss. Skurril.


Zurück zu „Hilfe! Computer!“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste